Issue
Agility or Analytics is not functional after updating the SQL username and password for the enterprise.
Affected Products & Versions
Any
Cause
There is a mismatch of the SQL user, username, and password in the application config files vs what the customer has set the SQL username and password to be in the enterprise.
Workaround/Resolution Action
The following is the process for updating SQL usernames and passwords in Agility and Analytics:
- Run the Agility, Analytics, and Datamart installers for the version you want to run in your environment
- Uninstall all of the applications. Make sure you do not delete the VersionOne database during the uninstall process. The Analytics DB and Datamart do not matter as they are recreated during those installs.
- Re-install VersionOne. When doing the reinstall, use the option to use SQL user credentials provided by my DBA. Enter your SQL user name there and the current password.
- Connect to the existing VersionOne database and then let the setup complete
- Do the same steps for the Datamart install. The new datamart will be created during this setup process.
- Do the same for the Analytics install. Again, the Analytics database will be created during the setup process
Doing the above steps is necessary (and the easiest way) to get the application set to use a provided SQL username and password.
Once all three applications are installed, configured (any custom files replaced and lic. dropped in), and tested as accessible and working, you need to make the following changes:
- Create a user.config file with the connection string below and place that file in the following
directory - c:\inetpub\wwwroot\YourV1ApplicationName\ - (for the VersionOne application)
<add key="ConnectionString" value="Data Source=xxxxx;Initial Catalog=VersionOne;User ID=
{username}Password={password};Enlist=False;Pooling=True;Connect Timeout=5;Application
Name="xxxxx (xxxxxx)"" /> - Create a user.config file with the connection string below and place that file in the following
directory - c:\inetpub\wwwroot\YourAnalyitcsApplicationName\ - (for the Analytics application)
When you have to change a password, you must update the password in the above connection strings in the user.config files.
<add key="ConnectionString" value="Data Source=xxxxx;Initial Catalog=VersionOne;User ID=
{username};Password={password};Enlist=False;Pooling=True;Connect Timeout=5;Application
Name="xxxxx (xxxxxx)"" />
In addition to the creation of the user.config files, the following changes will also need to be made:
A. Data Mart changes:
- The ETL Configuration file, VersionOne.DatamartLoader.exe.config. Located in the ETL sub-directory
- The _Settings.lgx file is located in the _Definitions folder under the ETL sub-directory
The ETL folder is located under C:\Program Files\VersionOne\ in a folder that is named for your VersionOne instance. By default, the ETL folder name is {VersionOne instance name} to {VersionOne instance name}-datamart.
B. Analytics:
- The _Settings.lgx file is located in the _Definitions folder under the Analytics install location
- The _Settings.lgx file is located in the AdHoc/_Definitions folder under Analytics install location
Once all of the above changes are made, your application will be properly setup to be able to accept your routine password change requirements. Every Time you have a required password change, you will need to update the password in all of the files listed above.
You do not have to do the uninstalls and reinstalls if you feel comfortable updating the necessary files but running the installers is an easier way as they will make the necessary changes automatically.
Considerations
If during the initial install directories other than the default directories were used, the above files may be located in different locations. You will need to find out what those locations are and document them for your records.
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