Issue: A duplicate name exists on the network with Digital.ai Deploy

Issue

The error "A duplicate name exists on the network" is returned when running Check Connection on an overthere.CifsHost configured with a domain name. Check connection is successful when using the IP address instead.

Environment

Digital.ai Deploy, Windows, CIFS, DNS

Cause

The root cause of the issue is related to how older smb implementations (including the current jcifs that ships with Digital.ai Deploy) work with a host that has an IP address resolved to by more than one name. Often it is when a computer name record and a CNAME in DNS point to the same IP address. This will happen with other name resolution as well (WINS, hosts file, etc.).

Resolution

Create a new 32bit DWORD named DisableStrictNameChecking and set its value to 1 in HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services > lanmanserver > Parameters

From an Administrator command prompt, run - sc stop LanmanServer, and then - sc start LanmanServer

You may also need to proceed with the following:

  • SPN created on the remote server: setspn –S host/<hostname.domain.name> <hostname>
  • SPN created on the remote server: setspn –S host/<hostname> <hostname>

 

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