Release: Deadlock error related to Quartz

Issue

The Release application is getting stuck, and the following error is noticed in the logs:

FINEST|18613/0|Service XL Release Server|25-04-12 18:24:06|2025-04-12 18:24:06.547 [xlrQuartz
Scheduler_QuartzSchedulerThread] {dd.service=wrapper} ERROR org.quartz.core.ErrorLogger - An
error occurred while scanning for the next triggers to fire.
FINEST|18613/0|Service XL Release Server|25-04-12 18:24:06|org.quartz.JobPersistenceException:
Couldn't acquire next trigger: Transaction (Process ID 203) was deadlocked on lock resources
with another process and has been chosen as the deadlock victim. Rerun the transaction.

Affected Products & Versions

Release 23.x, 24.x

Cause

These types of errors can occur when the database is under heavy load, and Quartz is unable to acquire the necessary lock via the QRTZ_LOCKS table. Note that MSSQL has some specific behavior in this context and requires a slightly different configuration.

Workaround/Resolution Action

Please check if your quartz.properties file located in the <Release_Home>/conf directory includes the following line:

org.quartz.jobStore.acquireTriggersWithinLock=true

Our documentation outlines this setting: Configure the Release SQL Repository in a Database.

If it is not present, add the file with the above content, ensure it has the correct ownership and permissions, and restart the Release service. This should resolve the trigger-related deadlock error.

 

 

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