Issue: Unable to import packages when Deploy is run as Service

Issue

Unable to import a package (from Computer or Deploy Server) in Deploy. It only happens when Deploy is run as a service on Windows.

You may get an access denied message suggesting that you don't have permissions on the TEMP directory.

Caused by: java.io.FileNotFoundException: C:\WINDOWS\TEMP\3039406529\petclinic-1.0.dar (Access
is denied)

Affected Products & Versions

Noticed in Deploy v.23.3.x running as a service in a Windows environment.

Cause

Changes to the Guava library.

Steps to Recreate

Install Deploy 23.3.x as a service in a Windows server. The environment in which we re-created the issue:

  • Deploy v.23.3.2 run as service
  • OS:Windows Server 2019/2022
  • DB: MSSQL Database

Workaround/Resolution Action

Please remove the bundled Guava library (guava-32.1.2) included in Deploy version 23.3.2. Replace it with its next version, ie. guava-32.1.3-jre.jar. To obtain the new JAR file, reach out to the support team.

  1. Stop Deploy service
  2. Remove the bundled Guava library (guava-32.1.2.jar) from <Deploy_Home>/lib
  3. Add the new guava library(guava-32.1.3-jre.jar) to <Deploy_Home>/lib
  4. Start Deploy as service

Ref: https://github.com/google/guava/releases/tag/v32.1.3

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